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MODELOWANIE I ANALIZA CHWYTAKA ROBOTA
PRZEMYSLOWEGO

Streszczenie: W artykule przedstawiono projektowanie chwytaka zdolnego
przenies¢ element klasy walek o maksymalnej srednicy 65 mm i dlugosci
120 mm. Chwytak zostal zaadaptowany do robota przemystowego IRB. Jego
czes¢ manipulacyjna jest napedzana silnikiem elektrycznym, a naped
przenoszony za posrednictwem przektadni zebatej. Projekt w catosci zostat
wykonany w programie inzynierskim Catia. Cze¢s¢ obliczen zostata wykonana
drogq analityczng, a niektore obliczenia wykonano przy uzyciu wyzej
wymienionego programu metodq elementow skonczonych. Po ukonczeniu
wszystkich obliczen i zamodelowaniu wszystkich elementow, zostata
utworzona symulacja pokazujgca przyktadowy zatadunek watka do tokarki
sterowanej numerycznie OSA 200.

MODELING AND ANALYSIS OF INDUSTRIAL ROBOT GRIPPER

Abstract: The paper presents the design of the gripper capable move the
roller element class with a maximum diameter of 65 mm and a length of 120
mm. The gripper is adapted to an industrial robot IRB. The handling part of
will be driven by an electric motor and the drive have to be transferred via
the gear train. The project as a whole was made in the engineering program
Catia. Part of the calculation was made through an analytical, some
calculations were made using the above-mentioned FEA. When it is
completed calculations and modeling of all the elements, was created
a simulation showing the sample loading roller CNC lathe OSA 200.

Stowa  kluczowe: chwytak robota przemystowego, analiza MES,
projektowanie, symulacja dzialania chwytaka, CATIA

Keywords: industrial robot gripper, FEM analysis, design, simulation of
a gripper, CATIA

1. WPROWADZENIE
Wszedzie, gdzie ludzka reka nie ma dostgpu lub moze to zagraza¢ zyciu czlowieka, dla

bezpieczenstwa najlepiej umiesci¢ tam robota. Takie rozwigzanie daje duzo mozliwosci.
Ograniczenia zalezg tylko od parametréw technicznych robota. Roboty moga by¢ silniejsze,
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precyzyjniejsze od ludzi, moga pracowaé caty czas bez odpoczynku w niebezpiecznym
otoczeniu 1 bez wigkszego ryzyka, poniewaz jesli co$§ pdjdzie nie tak, robot prawdopodobnie
ulegnie uszkodzeniu 1 nastepnym razem silniejszy 1 bardziej odporny na uszkodzenia moze
by¢ uzyty w jego miejsce. W robotach waznym elementem jest czes¢ chwytajaca. To od niej
zalezy, do czego moze by¢ przeznaczony dany robot i jaka funkcje bedzie spetniat. Dzigki
specjalnie skonstruowanemu chwytakowi mozemy przyspieszy¢ prace wykonywane przez
roboty. Chwytak jest najbardziej zrdéznicowang czg¢scig robota. Réznig si¢ one rodzajem
napedu, ukladem przeniesienia napgdu, ukladem wykonawczym, rodzajem koncowek
chwytnych, sposobem trzymania detalu. Na rynku istniejg oprogramowania wspomagajace
dobor chwytakow. Zazwyczaj sg to programy z chwytakami oferowanymi przez konkretnego
producenta, zamieszczonymi na stronach internetowych. Istniejg rdéwniez programy
komputerowe, ktore pozwalajg na modelowanie 3D, np. Catia, Solid Works, Solid Edge,
Unigrafix, Pro/Engineer, utatwiajace proces projektowania chwytaka robota przemystowego.
Przy wuzyciu odpowiednich programoéw, np. Catia, mozemy symulowaé dziatanie
zaprojektowanego mechanizmu bez potrzeby tworzenia rzeczywistego modelu oraz mozemy
dokona¢ analizy metoda elementow skonczonych. Chwytaki sa uzywane do manipulacji
przedmiotow o zrdéznicowanym ksztalcie 1 w r6znych warunkach, w jakich musza pracowac.
Na ogot stosuje si¢ chwytaki specjalnej budowy przeznaczone do chwytania okreslonych
przedmiotow. Okoto 60-70% uzywanych chwytakow trzeba bylo specjalnie konstruowac,
a tylko 30-40% to chwytaki znormalizowane oferowane przez producentow [7]. Niezbednym
wyposazeniem robota przemystowego wykonujacego zadanie transportowe w procesie
produkcyjnym jest chwytak [1]. Skfada si¢ on z trzech uktadow: napedowego, przeniesienia
napedu 1 ukladu wykonawczego. Funkcje uktadu napedowego moze speinia¢ sitownik
(pneumatyczny, hydrauliczny, elektromagnetyczny) oraz silnik elektryczny. Maja one za
zadanie wygenerowa¢ odpowiednia site. Uklad przeniesienia napedu ma za zadanie
przeniesienie sily z uktadu napedowego na uktad wykonawczy. Wszystkie trzy wymienione
uktady mogg wspodtdziata¢ z systemem sensorycznym. Uktady wykonawcze chwytakow sg
najczesciej wyposazone w roéznego rodzaju czujniki. Powszechne stalo si¢ stosowanie
programow komputerowych do wspomagania doboru odpowiedniego typu chwytaka. Znani
producenci chwytakow tworza programy, za posrednictwem ktorych mozna dopasowac
odpowiedni chwytak w kilka chwil. OczywiScie w danym programie znajduja si¢ tylko
chwytaki proponowane przez danego producenta [6]. Przyktadem moze by¢ firma FESTO,
ktora na swojej stronie internetowej zamiescita aplikacje do wyszukiwania chwytaka
w zaleznosci od oczekiwan klienta. Chwytaki sa niezbedng czescig robota. Robot bez
czgsci chwytajacej nie moglby wykonywaé zbyt wielu zadan. W licznych procesach
technologicznych wymagana jest duza dokladno$¢ pozycjonowania przedmiotu
manipulowanego. Uzyska¢ to mozna dzigki zastosowaniu odpowiedniego chwytaka
wyposazonego w roéznego rodzaju systemy wizyjne, sensory czy czujniki. Chwytak ma
wspolpracowac z robotem przemystowym IRB 1 stuzy¢ do przenoszenia detalu typu watek.
Jest napedzany krokowym silnikiem elektrycznym, a przeniesienie napedu odbywa si¢
poprzez przekladnie katowa. Maksymalna $Srednica 1 dtugo$¢ przenoszonego przedmiotu to
?65 mm 1120 mm [8].

2. PRACA Z SYSTEMEM CATIA

CATIA to jeden z najbardziej rozbudowanych 1 wszechstronnych programéw wspomagania
prac inzynierskich w zakresie projektowania, tworzenia dokumentacji plaskiej, symulacji
metodg elementow skonczonych MES oraz programowania obrobki na maszynach
numerycznych typu CNC. Oprogramowanie jest najpowszechniej wykorzystywane
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w przemysle samochodowym i lotniczym. Doskonale sprawdza si¢ w projektowaniu
wyroboéw AGD, form wtryskowych, tlocznikéw, wykrojnikéw, elementow z blach, tworzyw
sztucznych, kompozytow, linii produkcyjnych 1 wielu innych. Umozliwia wirtualne
sprawdzenie ergonomii projektowanego wyrobu. Oprécz funkcji CAx oferuje narzedzia
PDM/PLM (SmarTeam, Enovia) pozwalajace na zarzadzanie cyklem zycia produktu
(tworzeniem, rozwojem, dokumentacja, cyklem zycia itd.).

Zbudowany jest z duzej liczby modutdw. Ponizej na przykladzie projektowania chwytaka
robota przemystowego omowiono tylko niektére z modutdow, jakie posiada ten program,
a mianowicie modul stuzacy do modelowania brylowego, tworzenia zlozen, analizy
kinematycznej oraz modut do analizy naprezen [8].

2.1. Zasady modelowania brylowego

Modelowanie brylowe zostalo opisane na podstawie wykonania watu z nacietym gwintem M6
co zostato przedstawione na rysunku 1.

Rys. 1. Model watu z nacigtym gwintem

Modelowanie zacz¢to od wyboru odpowiedniego moduhlu Start > Mechanical Design > Part
Design. Model ten mozna wykona¢ na dwa sposoby. Pierwszym jest narysowanie profilu
walu tak jak na rysunku 2.

Rys. 2. Zarys walu
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Nastepnie nalezy uzy¢ opcji do obrotu profilu wzgledem zadanej osi Shaft. W opcji tej trzeba
wybra¢ kat obrotu, obracany profil oraz 0§ obrotu. Na rysunku 3 przedstawiono efekt tej
operacji.

Rys. 3. Watl po wykonaniu obrotu profilu wzglgdem osi

Kolejng metoda jest dodawanie kazdej cz¢s¢ watu osobno przy pomocy opcji wyciggania
profilu Pad. Na poczatku nalezy narysowac pierwszy profil. Przy uzyciu opcji Pad
wyciggamy profil na odpowiednig dlugos¢. Nastepnie trzeba doda¢ kolejny czlon, uzywajac
opcji szkicowania Sketch na powierzchni, do ktorej trzeba doda¢ kolejny czlon. Nastepnie
nalezy narysowac profil i wyciaggnaé go jak poprzednio. Kolejne cztony nalezy doda¢ w ten
sam sposob do uzyskania takiego samego efektu jak w pierwszej metodzie. Gdy mamy juz
gotowy wal, wykonujemy gwint. Nalezy zacza¢ od utworzenia nowego ciata Body
(Insert>Body). Nastepnie tworzymy krzywa, (Helix) spirale wzdluz wahi. Aby tego dokonacé,
nalezy najpierw narysowac punkt zaczepienia spirali. We wilasciwosciach spirali nalezy
wprowadzi¢ warto$ci odpowiadajace parametrom gwintu. Kolejnym krokiem jest
narysowanie profilu ksztaltu gwintu. Majac juz spirale i profil, nalezy uzy¢ opcji Rib
wszystkie opcje nalezy ustawi¢ jak na rysunku 4.

Rib Definition ? %]

Profile @
Center curve W@

Profile control

Puling direction -
Selecti ad. 1Axis. 1
[ Move profile to path

[ Merge rib's ends [ Thick Profile
Thin Rib

Rys. 4. Operacja Rib
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Ostatnig operacja jest usuniecie utworzonej bryly (Body.2) z ciata pierwszego (PartBody)
Insert > Boolean Operations > Remove. Te same operacje nalezy wykona¢ symetrycznie
w drugiej czgsci walu.

2.2. Tworzenie zlozen

Tworzenie zlozen nalezy wykona¢ za pomocg modutu Assembly Design. Nalezy otworzy¢
modut Start > Mechanical Design > Assembly Design.

Rys. 5. Czesci do zlozenia

Tworzenie zlozenia polega na dodawaniu gotowych elementéw i zadawaniu odpowiednich
relacji zachodzacych miedzy nimi. Powigzania, jakie nalezy wybraé, to wspotosiowosc,
kontakt, odstgp, nachylenie pod katem, utwierdzenie i utwierdzenie razem kilku czesci.
Sktadanie rozpocza¢ nalezy od dodania czesci, z ktdrych bedzie sktadato si¢ ztozenie. Mozna
dodawaé czesci pojedynczo i na biezagco nadawac relacje miedzy czg¢sciami lub dodaé
wszystkie czgsci 1 dopiero wtedy nadawacé relacje migdzy czg$ciami, co moze by¢ utrudnione
przy duzej ich ilosci. Na rysunku 5 przedstawiono zbior czg$ci z zadeklarowanymi
powigzaniami miedzy nimi. Po zadeklarowaniu wszystkich powigzan wystarczy nacisngé
ikonke¢ update, aby automatycznie potaczy¢ wszystkie czgsci.

2.3. Analiza naprezen

Analiza naprezen zostanie przeprowadzona na przykladzie watlu zaprojektowanego
w poprzednim punkcie 2.1. Badany element przedstawia rysunek 6.
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Rys. 6. Badany wat

Aby rozpocza¢ analize napr¢zen, najpierw nalezy otworzy¢ plik z badanym elementem,
a nastgpnie uruchomi¢ odpowiedni modut, klikajac Start > Analysis & Simulation >
Generative Structural Analysis. Nastepnie wybra¢ Static analysis. Pierwszg czynno$cig bedzie
utwierdzenie watu podporami przy uzyciu opcji Clamp. Nastepnie nalezy obcigzy¢ wat
sifami, momentem gnacym réwnym 0.4 Nm. Po utwierdzeniu 1 zadaniu sit nalezy uruchomic¢
obliczenia ikong Compute — rysunek 7.

Rys. 7. Uruchamianie obliczen

Obliczenia badanego modelu moga potrwac od kilku sekund do kilku godzin, w zaleznos$ci od
tego, jak bardzo skomplikowany element badamy. Na rysunku 8 przedstawiono napre¢zenia
zredukowane, jakie powstaly w badanym modelu. Maksymalne powstale napr¢zenia wynosza
17 MPa. Maksymalne przemieszczenie w badanym przedmiocie jest bardzo mate 1 wynosi
0,004 mm.

Rys. 8. Naprezenia

Przeprowadzona analiza wykazata, ze watl zostal dobrany poprawnie, wartosci przemieszczen
sa bardzo mate, a napr¢zenia maksymalne s3 mniejsze od dopuszczalnej wytrzymatosci
materiatu, z ktorego skonstruowany jest wal.
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2.4. Analiza kinematyczna

Aby wykona¢ analiz¢ kinematyczng, najpierw nalezy polaczy¢ silnik, sprzggto, wat oraz koto
zgbate. Analiza kinematyczna tego ukfadu polega na zadaniu ruchu obrotowego walowi
silnika i nadaniu relacji migdzy sprzegtem, walem 1 kotem zgbatym, aby poruszaty si¢ wraz
z obrotem walu silnika. Nalezy utworzy¢ nowe zlozenie lub otworzy¢ gotowe, a nastgpnie
uruchomi¢ modut do analizy kinematycznej Start > Digital Mockup > DMU Kinematics. Na
poczatku nalezy utworzy¢ nowy mechanizm (Insert > New Mechanism). Kolejny krok to
nadanie ostoi mechanizmu (Insert > Fixed Part) i klikniecie na korpus silnika. Teraz wat
silnika nalezy wprowadzi¢ w ruch obrotowy, uzywajac do tego opcji Revolute Joint (Insert >
New Joint > Revolute Joint). Aby opcja ta dziatata poprawnie, nalezy zaznaczy¢ o$ watu
i silnika oraz ich powierzchnie prostopadte do osi obrotu, pozostale opcje ustawi¢ jak na
przedstawionym rysunku. Po zaakceptowaniu mozna juz symulowaé obrét watu, klikajac
ikone Simulation with Commands. Teraz tgczymy wat silnika ze sprzegltem, uzywajac do tego
opcji Rigid Joint. W opcji tej nalezy wskazaé wat silnika, a nastgpnie sprzeglo,
i zaakceptowaé. Do wskazywania czg$ci najlepiej uzy¢ drzewka elementéw, znajdujacego sie
w lewym gérnym rogu. Tak samo taczymy pozostale czesci naszego ukltadu. Po ukonczeniu
efekt zlozenia kinematycznego mozna sprawdzi¢, uruchamiajgc symulacje za pomocg
komend Simulation with Commands i za pomocg suwaka symulowaé¢ ruch obrotowy watu
silnika, co zostalo przedstawione na rysunku 9.

Kinematics Simulatien - Mechanism. 1
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3. ANALIZA MODELU CHWYTAKA

W pierwszej fazie projektowania chwytaka zostal utworzony jego model pogladowy,
z uwzglednieniem wymaganego nape¢du 1 jego przeniesienia.

Rys. 10. Ztozenie chwytaka w programie Catia i analiza napr¢zen badanej tapy

Po przeprowadzeniu wstepnych obliczen, dobraniu znormalizowanych cze$ci oraz czesci
mozliwych do nabycia za pomoca serwisOw internetowych, projektowany chwytak przyjat
posta¢ przedstawiong na rysunku 10. Po wstepnym przyjeciu budowy chwytaka zostaty
wykonane obliczenia metoda elementow skonczonych w programie Catia. Jednym
z elementow badanych byla tapa chwytajaca chwytaka, aby wyeliminowa¢ wystgpowanie
naprezen wigkszych niz dopuszczalne. Analiza napr¢zen zredukowanych przedstawia rysunek
10. Jak wida¢ na rysunku, duza czg¢s¢ badanego elementu jest obcigzona sita nie wigksza niz
15 MPa. Najwigksze obcigzenia wystepuja w tulejach slizgowych, ktore wspotpracuja
z prowadnicami. Poza analiza naprezen mozna rowniez zobaczy¢, jakie przemieszczenia
wystepuja w badanym elemencie po obcigzeniu go zadang sitg. Maksymalne przemieszczenia
w badanym elemencie wynosza 0,1 mm. Kolejnym elementem badanym metoda elementéw
skonczonych bylo zlozenie kilku elementow chwytaka. Analiza tego ztozenia ma polega¢ na
sprawdzeniu maksymalnego wychylenia watu w miejscu osadzenia kota zgbatego. Gdyby
wychylenie to bylo zbyt duze, nalezaloby zastosowac¢ dodatkowe lozysko migdzy sprzegtem
a kolem z¢batym, co spowodowaloby zmiany w konstrukcji chwytaka. Z przeprowadzone;j
symulacji wynika, ze maksymalne przemieszczenia wynosza 0,185 mm 1 uzycie dodatkowego
fozyska jest zbedne w projektowanym chwytaku. Kolejnym problemem do rozwigzania byta
sifa zacisku. Z przeprowadzonych obliczen wynika, ze zastosowany silnik generuje za duza
sife uchwytu przy maksymalnej mocy (okoto 600 N), przy wymaganych niecatych 100 N.
Roéznice t¢ mozna zmniejszy¢ przez zwigkszenie ilosci obrotow na minute. Przy momencie
obrotowym réwnym 0.2 Nm ponownie wyliczona sita przeniesiona przez srube rzymska, przy
uwzglednieniu wszystkich strat, wynosi okoto 130 N. Nalezy zatem uzy¢ generatora, ktory
bedzie tworzyl czestotliwos¢ wyjsciowa okoto 3100 Hz. Przy podanej czestotliwosci
predkos¢ obrotowa uzytego silnika bgdzie wynosi¢ okoto 120 obrotéw na minut¢. Moment
obrotowy mozna bylo zmniejszy¢ poprzez zastosowanie odpowiedniego przetozenia na
przektadni, ale spowodowaloby to niepotrzebny wzrost wielkosci chwytaka. Silnik,
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przekladnia i elementy mocujace uzyte do budowy chwytaka sg elementami typowymi
i dobranymi z katalogu [9].

4. SYMULACJA DZIALANIA CHWYTAKA

Przy pomocy programu inzynierskiego Catia zostala wykonana przykladowa symulacja
dzialania projektowanego chwytaka. Do wykonania symulacji nalezy utworzy¢ dodatkowe
zespoty urzadzen, ktore moga wspdlpracowac z projektowanym elementem (robot IRB oraz
Tokarka CNC OSA 200).

Rys. 11. Sterowanie mechanizmem za pomoca komend

Nastepnie wykonuje si¢ zlozenie wszystkich elementéw w jedng calo$¢ za pomoca
omawianego wczesniej modulu do tworzenia zlozen. Kolejnym krokiem jest utworzenie
polaczen migdzy elementami, uzywajac modutu do analizy kinematycznej. Nastepnie
tworzymy symulacje za pomoca komend. Na rysunku 11 wida¢ zlozenie wszystkich czesci
iuruchomiong opcj¢ sterowania za pomoca komend. Zmieniajac odpowiednio wartosci
katowe poszczegdlnych suwakow, sterujemy odpowiednio przypisanymi im czlonami.
Suwakami mozna sterowa¢ pojedynczo lub wszystkimi jednocze$nie. Granice obrotu
poszczegolnych cztonow sa ustalane przy tworzeniu schematu kinematycznego i nadawaniu
ruchu elementom ruchomym w module DMU Kinematics.

5. WNIOSKI

Celem opracowania bylo zaprojektowanie chwytaka robota przemystowego. Chwytak ten jest
zaprojektowany dla robota IRB do przenoszenia watkow o $rednicy 65 mm i dhlugosci
120 mm. Ograniczenie to wynika z mozliwosci robota, ktérego udzwig wynosi okoto 6 kg,
przy wadze samego chwytaka wynoszacej okoto 2 kg. Jest to jedna z jego wad. Do zalet
mozna zaliczy¢ prostag budowe chwytaka, mozliwos$¢ szybkiej zmiany koncowek chwytnych.
Aby przystosowac¢ chwytak do pracy z innym robotem, wystarczy zaprojektowac jego czes$¢
faczaca z nowym robotem. W projektowanym chwytaku wykorzystywane jest tylko okoto
25% mocy. Przy wspolpracy z robotem o wigkszym udzwigu wystarczy zmniejszyé
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czestotliwos$¢ na wyjsciu generatora, co zmniejszy predkos¢ obrotowa 1 zwigkszy moc silnika.
Pozwoli to na przenoszenie wigkszych elementéw. Obliczenia projektowe zostaty czgsciowo
wykonane analitycznie, a do niektérych wykonano obliczenia metoda elementéw
skonczonych przy uzyciu programu Catia. Zaprojektowany chwytak spetnia zalozenia
projektowe 1 bedzie speinial swoje zadania. W dalszych badaniach nalezy wykona¢ prototyp,
zaprojektowacé rézne koncoéwki chwytne do przenoszenia innych elementow, niekoniecznie
watkow, sprobowa¢ zredukowaé mase uzywajac innych materiatdw, w zaleznosci od
obcigzen, jakie beda wystepowaty podczas jego pracy.
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